HyperFileSQL – importer un fichier Excel dans la base de données HyperfileSQL

Importer les données à partir d’un fichier Excel  vers une table HyperFileSQL est tout à fait possible et simplement réalisable en WLangage.

Voici la structure du fichier Excel (2 colonnes * 604 lignes)

 

Et voici la structure de ma table HyperFileSQL

 

Colonne A du fichier Excel va être importée vers « code_langue »

Colonne B du fichier Excel va être importée vers « traduction »

Le code:

 

XLSFileHandler est un entier //file handler
nombre_lignes est un entier //total lignes du fichier excel

SI fFichierExiste(« traductions-chinois-last.xls ») ALORS
HCréation(zbar_translate)
XLSFileHandler = xlsOuvre(« traductions-chinois-last.xls »)
nombre_lignes = xlsNbLigne(XLSFileHandler)
HOuvre(zbar_translate)
POUR cpt=1 A nombre_lignes
SI XLSFileHandler <> -1 ALORS
zbar_translate.code_langue= xlsDonnée (XLSFileHandler,cpt,1,Vrai)
zbar_translate.traduction= xlsDonnée (XLSFileHandler,cpt,2,Vrai)
zbar_translate.code_z = « Z02 »
HAjoute(zbar_translate)
FIN
FIN
SINON
Erreur(« Le fichier Excel traduction-chinois-last.xls n’existe pas »)
FIN

Bon dev!

 

Ce contenu a été publié dans Webdev, Windev, avec comme mot(s)-clé(s) , , , , , . Vous pouvez le mettre en favoris avec ce permalien.

3 réponses à HyperFileSQL – importer un fichier Excel dans la base de données HyperfileSQL

  1. Reginald dit :

    Moi jai importe la base excel ds lanalyse,et jai fait rad fenetre sur lanalyse,quand jexecute mn logiciel sur un otr pc,les donnees de ma base excel,st absentes. Cmt faire

  2. Auto_increment dit :

    Bonjour,
    merci pour votre code,vous venez de m’aider.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *